Browse Source

core: update latest nix requirements

master
parent
commit
311c0a2a98
Signed by: govanify GPG Key ID: DE62E1E2A6145556
2 changed files with 5 additions and 2 deletions
  1. +4
    -2
      components/headfull/graphical/wm.nix
  2. +1
    -0
      profiles/headfull.nix

+ 4
- 2
components/headfull/graphical/wm.nix View File

@ -424,8 +424,10 @@ in
# exploitable is ~0. It would have gathered those rights regardless if
# PolKit was installed, so this is just a workaround to avoid having the
# whole machinery
security.wrappers = {
sway.source = "${pkgs.sway}/bin/sway";
security.wrappers.sway = {
source = "${pkgs.sway}/bin/sway";
owner = "root";
group = "root";
};
systemd.user.services.swaywm = {


+ 1
- 0
profiles/headfull.nix View File

@ -81,6 +81,7 @@ with lib;
isSystemUser = true;
shell = pkgs.bash;
openssh.authorizedKeys.keyFiles = [ ./../secrets/headfull/assets/ssh/distbuild.pub ];
group = "distbuild";
};
nix.trustedUsers = [ "distbuild" ];


Loading…
Cancel
Save